您的位置 首页 龙岩新闻

单阳不破指标通达信主图波段短线操盘控盘

问题:怎样才能每天都收到这类文章!
答案:只需点击上方《翔博软件工作室》
做价值的传播者,路同行,一起成长




公式源码:


DRAWTEXT_FIX(C>O,0.01,0.9,0,’微信订阅号:翔博软件工作室’),COLOR556699;
DRAWGBK(C>0,RGB(150,50,175),RGB(0,25,100),0,’ ‘,0);
{DRAWGBK(O>C,RGB(360,0,10),RGB(10,0,1),0,’01’,0);}
N8:=STRCAT(CON2STR(YEAR,0),’年’);
Y8:=STRCAT(CON2STR(MONTH,0),’月’);
R8:=STRCAT(CON2STR(DAY,0),’日’);
N:=120;
K:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));{高点}
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));{低点}
KJ:=GD-DD;{高低点差值=分区高度}
GD4:IF(CURRBARSCOUNT<=N/30,GD,DRAWNULL);
低:IF(CURRBARSCOUNT<=N/30,DD,DRAWNULL),COLORFFFF00;
高:IF(CURRBARSCOUNT<=N/30,GD,DRAWNULL),COLOR00FFFF;
支撑:IF(CURRBARSCOUNT<=N/30,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;
强势: IF(CURRBARSCOUNT<=N/30,DD+KJ*0.382,DRAWNULL),COLORFF00FF;
突破:IF(CURRBARSCOUNT<=N/30,DD+KJ/2,DRAWNULL),COLOR0000FF;
警示:IF(CURRBARSCOUNT<=N/30,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;
压力:IF(CURRBARSCOUNT<=N/30,DD+KJ*0.809,DRAWNULL),COLOR00FF00;
低涨:IF(CURRBARSCOUNT<=N/30,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
天数:BARSLAST(L=DD),COLORCYAN,NODRAW;
今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299,NODRAW;
顶点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLOREAEAAE,DOTLINE;
低点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLOREAEAAE,DOTLINE;
STICKLINE(CCI>=200 AND H>=顶点,O,C,3,0),COLORBLUE;
STICKLINE(CCI<=100 AND L<=低点,O,C,3,0),COLORYELLOW;
DRAWBAND(高,RGB(200,200,0),压力,RGB(0,0,0));
DRAWBAND(压力,RGB(0,190,0),警示,RGB(0,0,0));
DRAWBAND(警示,RGB(220,120,0),突破,RGB(0,0,0));
DRAWBAND(突破,RGB(120,0,120),强势,RGB(0,0,0));
DRAWBAND(强势,RGB(120, 0,0),支撑,RGB(0,0,0));
DRAWBAND(支撑,RGB(80,80,80),低,RGB(0,0,0));
STICKLINE(CURRBARSCOUNT=N/30,GD,DD,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,GD,DD,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT<=N/30,支撑,支撑,4,0),COLORFF00FF;
STICKLINE(CURRBARSCOUNT<=N/30,强势,强势,4,0),COLORFF00FF;
STICKLINE(CURRBARSCOUNT<=N/30,突破,突破,4,0),COLORABABAB;
STICKLINE(CURRBARSCOUNT<=N/30,警示,警示,4,0),COLOR00FFFF;
STICKLINE(CURRBARSCOUNT<=N/30,压力,压力,4,0),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,压力,’0.809′),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,警示,’0.618′),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,突破,’0.500′),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=1,强势,’0.382′),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,支撑,’0.191′),COLOR00FFFF;
DA:(3*CLOSE+OPEN+LOW+HIGH)/6,POINTDOT;
DB:(20*DA+19*REF(DA,1)+18*REF(DA,2)+17*REF(DA,3)+16*REF(DA,4)+
15*REF(DA,5)+14*REF(DA,6)+13*REF(DA,7)+12*REF(DA,8)+11*REF(DA,9)+
10*REF(DA,10)+9*REF(DA,11)+8*REF(DA,12)+7*REF(DA,13)+6*REF(DA,14)+
5*REF(DA,15)+4*REF(DA,16)+3*REF(DA,17)+2*REF(DA,18)+
REF(DA,20))/210,COLORRED;
DC:MA(DB,5),COLORF0F000,LINETHICK1;
{DRAWBAND(DB,RGB(255,0,0),DC,RGB(0,255,0));}
DRAWBAND(DB,RGB(155,50,50),DC,RGB(83,123,68));
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORRED;
STICKLINE(C<O AND C>REF(C,1),C,O,3,0),COLORFFCC00;
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,3,0 ),COLOR000055;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.7,0 ),COLOR000077;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(C<REF(C,1) AND C>O,C,O,3,0),COLORFFCC00;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
阳涨幅:=4;
阳倍量:=2;
单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量;
DRAWTEXT(CURRBARSCOUNT<100 AND 单阳,L*0.98,’阳’),COLOR00FFFF;
高不破价:=REF(C,BARSLAST(单阳));
中不破价:=REF((C+L)/2,BARSLAST(单阳));
低不破价:=REF(L,BARSLAST(单阳));
单阳不破:=CURRBARSCOUNT<100 AND BARSLAST(单阳)<11 AND (LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价);
STICKLINE(单阳不破,低不破价-低不破价*0.003,低不破价,4,0),COLORRED;
DRAWTEXT(BARSLAST(单阳)=1 AND 单阳不破,低不破价*0.98,’1′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=2 AND 单阳不破,低不破价*0.98,’2′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=3 AND 单阳不破,低不破价*0.98,’3′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=4 AND 单阳不破,低不破价*0.98,’4′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=5 AND 单阳不破,低不破价*0.98,’5′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=6 AND 单阳不破,低不破价*0.98,’6′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=7 AND 单阳不破,低不破价*0.98,’7′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=8 AND 单阳不破,低不破价*0.98,’8′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=9 AND 单阳不破,低不破价*0.98,’9′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=10 AND 单阳不破,低不破价*0.98,’10’),COLORGREEN;
地量:=FILTER(LLV(AMOUNT,120)=AMOUNT,10);
STICKLINE(地量,CLOSE,OPEN,4,0),COLORGREEN;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
DRAWTEXT(地量,LOW,’ ↖地量’),COLORGREEN;
{价画直线指标 };
STICKLINE(ISLASTBAR,C,C,3333,-1),COLORWHITE;
{止盈止损}
买入价格:IF(CROSS((MACD.DIF),(MACD.DEA)),C,DRAWNULL),NODRAW;
AAA:=STICKLINE(买入价格,0,C,2,0),COLORRED;
AAC:=BARSLAST(AAA);
止盈价格:IF(C>=REF(C,AAC)*1.1,REF(C,AAC)*1.1,DRAWNULL),COLORMAGENTA,NODRAW;
止损价格:IF(C<=REF(C,AAC)*0.95,REF(C,AAC)*0.95,DRAWNULL),COLORGREEN,NODRAW;
{庄家成本}
A:=SUMBARS(V ,CAPITAL*1);{累计换手=100%的周期}
A1:=SUM(COST(10),A)/A;{在A周期里获利10%的平均价}
A2:=SUM(COST(20),A)/A;{在A周期里获利20%的平均价}
A3:=SUM(COST(30),A)/A;{在A周期里获利30%的平均价}
A4:=SUM(COST(40),A)/A;{在A周期里获利40%的平均价}
A5:=SUM(COST(50),A)/A;{在A周期里获利50%的平均价}
庄家成本:(5*A1+4*A2+3*A3+2*A4+A5)/15,LINETHICK2,COLORRED;
天天有更新,每日领福利。
1,翔博软件新产品发布推广;
2,各大炒股名师讲座课程。
3,每天发布的指标公式,右上点“分享”右下点“好看”后,加在线客服免费领取!
马上加微信:xiangbosoft回复“好看”参加,名额有限!
========================
提供服务如下:
1、转换 — 根据客户提供的电脑板或者手机版技术指标源码,转换成自己的手机软件使用
2、编写 — 按照客户定制指标时“提供的编写要求”,制作技术指标
3、修改 — 按照客户“提供的修改要求”,修改技术指标

特别提示:

有手机指标的转换 测试 编写需求的朋友, 请联系微信:xiangbosoft

一个聚百万原创指标公式圈子

原创价值分享公众号
ID:yungongshi

如何让你手上闲置的指标公式倍增价值,可能这是你几年来一直没有办法解决的问题.马上在公众号对话框回复”倍增”为你解答!

点击【阅读原文】查阅更多经典指标

为您推荐

发表评论

邮箱地址不会被公开。 必填项已用*标注